View unanswered posts | View active topics It is currently Fri Aug 01, 2014 3:53 pm



Reply to topic  [ 6 posts ] 
Arduino Leonardo not detected by Windows 
Author Message

Joined: Sat Dec 01, 2012 10:53 am
Posts: 2
Post Arduino Leonardo not detected by Windows
I'm using a Windows 7 Ultimate on my system. As soon as I connect my Arduino Leonardo to the system, Windows sends a message saying the USB device device has malfunctioned and cannot be detected. The board is detected under ports (COM and LPT) but there is a little yellow icon with a "!" in it next to it. It also gets detected under USB controllers as an unknown device. I've tried installing the drivers as instructed on arduino.cc but still this problem remains. Someone please help!


Sat Dec 01, 2012 11:21 am
Profile

Joined: Tue Oct 18, 2011 9:49 pm
Posts: 92
Post Re: Arduino Leonardo not detected by Windows
Windows shows the device malfunction error when you previously attempted driver installation and it went bad. So, as a safety measure, uninstall the device from Ports and the unknown device from USB category. Do not use any USB Hub. Remove all data cards, internet dongles, etc.

Now, connect the USB Cable to your PC and Leonardo. Wait for some time for Windows to show up the Found new hardware wizard.
Follow instruction from Step 1 from this post: Installing Arduino Uno R3 Board on Windows 7


Sat Dec 01, 2012 1:22 pm
Profile

Joined: Sat Dec 01, 2012 10:53 am
Posts: 2
Post Re: Arduino Leonardo not detected by Windows
@abhimanyu Tried what you said. Still didn't work. I think we even talked over the phone a while back about this. I even tried installing it on another computer running Windows. Could it be a problem with the device?


Fri Dec 28, 2012 12:25 pm
Profile

Joined: Tue Oct 18, 2011 9:49 pm
Posts: 92
Post Re: Arduino Leonardo not detected by Windows
Can you post a screenshot of your Device manager?
Also, what is the activity of LEDs on the Leonardo Board?


Fri Dec 28, 2012 4:24 pm
Profile

Joined: Thu Aug 15, 2013 3:03 pm
Posts: 2
Post Re: Arduino Leonardo not detected by Windows
I'm using a Windows 7 home premium on my system. As I connect my Arduino Leonardo to the system, Windows sends a message saying the USB device device has malfunctioned and cannot be detected. In device manager there is a little yellow icon with a "!" in it next to it. It also gets detected under USB controllers as an unknown device. I've tried installing the drivers as instructed on arduino.cc but still this problem remains.
i had tried more methods by google and other webs
but my pc is showing a bad-pool-call message and ask for restart windows normally.

i am using nokia's original micro b usb cable. is it possible that problem is within cable.??


Thu Aug 15, 2013 3:22 pm
Profile

Joined: Tue May 01, 2012 8:30 am
Posts: 10
Post Re: Arduino Leonardo not detected by Windows
Follow steps from here:

http://forum.explorelabs.com/post1293.html#p1293

PRANSHU wrote:
I'm using a Windows 7 home premium on my system. As I connect my Arduino Leonardo to the system, Windows sends a message saying the USB device device has malfunctioned and cannot be detected. In device manager there is a little yellow icon with a "!" in it next to it. It also gets detected under USB controllers as an unknown device. I've tried installing the drivers as instructed on arduino.cc but still this problem remains.
i had tried more methods by google and other webs
but my pc is showing a bad-pool-call message and ask for restart windows normally.

i am using nokia's original micro b usb cable. is it possible that problem is within cable.??


Sun Aug 18, 2013 12:09 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software

phpBB SEO