Arduino Leonardo - Cannot upload code.

Discuss everything related to Arduino - Open-source electronic prototyping platform allowing to create interactive electronic objects.
sherin
Posts: 8
Joined: Tue Jul 03, 2012 3:33 am

Re: Arduino Leonardo - Cannot upload code.

Postby sherin » Fri Jul 06, 2012 1:57 pm

Now the code uploading is giving a success.
But I can upload the code even without connecting the device !!!!
But nothing happens at the device side. I have tried the reset button. Changed the delay in the blink code and uploaded, but still the board led keeps blinking fast always.
I tried the same in a second ubuntu machine, but the result is exactly the same.
I am unable to install the driver in windows and which an Explore Labs guy tried to solve, but he couldn't.
The device is shown as /dev/ttys0 in the arduino software.

I am planning to ship this product back to explore labs. So that the people there can have it tested at their hands.
sherin
Posts: 8
Joined: Tue Jul 03, 2012 3:33 am

Re: Arduino Leonardo - Cannot upload code.

Postby sherin » Fri Jul 06, 2012 1:58 pm

I strongly believe that the board needs to be replaced.
Max
Posts: 6
Joined: Tue Jul 03, 2012 6:33 am

Re: Arduino Leonardo - Cannot upload code.

Postby Max » Fri Jul 06, 2012 2:32 pm

But I can upload the code even without connecting the device !!!!


This is just because the code is not uploading actually and LEDs are blinking as Blink Code is loaded by default in Leonardo. IDE is not able to MAP your device to any port. Thus, code is not being uploaded and running the default in all cases.

I strongly feels that this is an issue of Port mapping rather than hardware. As per best of my knowledge, its most likely because board is not being recognized by your system.
The reason behind my belief that your board is OK is its executing a default blink code pretty well as mentioned by you in your previous post.

About your windows problem, its not that board is faulty. I am windows engineer and I can say that drivers installation failure is caused by various reasons and its not hardware at the fault always. If windows cant find necessary files, driver installation fails.

The Explore Labs guy who contacted you is Hardware Expert and is not a OS or a Software Geek.
So, that's why he couldn't solve your OS and Installation issue part in first shot.

Anyways, try uploading some another piece of code and let me know if its working or not. As blink code will work in any case as it is loaded by default.

If still problem persists, just mailto: support[at]explorelabs[dot]com for testing/replacement.
sherin
Posts: 8
Joined: Tue Jul 03, 2012 3:33 am

Re: Arduino Leonardo - Cannot upload code.

Postby sherin » Sat Jul 07, 2012 2:26 am

Oh great day !!!!
I solved it myself.
It all happened because of the poor quality USB cable.
I replaced the cable and now everything is working fine.
Driver problem solved and everything solved.
Thank you very much Explore Labs.
yash92ec
Posts: 1
Joined: Wed Sep 26, 2012 12:46 pm

Re: Arduino Leonardo - Cannot upload code.

Postby yash92ec » Wed Sep 26, 2012 6:23 pm

hello sir...
i have arduino leonardo board.there is a problem while uploading a program.
when i connected a arduino board to my PC before 2 days ago it was work successfully...
but suddenly,now i connect board to PC the option "serial port" is not available.
when i try to upload the program it gives error that no device attached to PC.
I also tried to upload the program from another PC but it gives the same error..
so please give me solution what to do...
virus
Posts: 10
Joined: Tue May 01, 2012 8:30 am

Re: Arduino Leonardo - Cannot upload code.

Postby virus » Thu Sep 27, 2012 1:53 pm

yash92ec wrote:hello sir...
i have arduino leonardo board.there is a problem while uploading a program.
when i connected a arduino board to my PC before 2 days ago it was work successfully...
but suddenly,now i connect board to PC the option "serial port" is not available.
when i try to upload the program it gives error that no device attached to PC.
I also tried to upload the program from another PC but it gives the same error..
so please give me solution what to do...


Which OS and version of Arduino IDE?

It will help us troubleshoot your problem faster.
arrowbenz
Posts: 3
Joined: Mon Dec 17, 2012 8:52 am

Re: Arduino Leonardo - Cannot upload code.

Postby arrowbenz » Mon Dec 17, 2012 9:02 am

Recently i bought ARDUINO LEONARDO when i connected it to my computer usb port . A message is display that "USB is not able to recognized" & below is the screen shot of device manager. It indicate a CODE 10 problem. what to do now?
Attachments
fault.jpg
fault.jpg (96.68 KiB) Viewed 3524 times
abhimanyu
Posts: 94
Joined: Tue Oct 18, 2011 9:49 pm

Re: Arduino Leonardo - Cannot upload code.

Postby abhimanyu » Mon Dec 17, 2012 9:49 am

Can you post the Vendor ID and Product ID of you Board?
You need to Go to Device Manager -> Ports (COM & LPT) -> Right Click Arduino Leonardo (COM13).
Click Properties -> Details (tab) -> Select Hardware Ids under Property Dropdown.
Post your VID, PID here. These should match the driver that you are trying to install.
arrowbenz
Posts: 3
Joined: Mon Dec 17, 2012 8:52 am

Re: Arduino Leonardo - Cannot upload code.

Postby arrowbenz » Mon Dec 17, 2012 3:28 pm

VID & PID ids are as below:

usb\vid_2341&pid_0036
Attachments
fault1.jpg
fault1.jpg (40.96 KiB) Viewed 3522 times
abhimanyu
Posts: 94
Joined: Tue Oct 18, 2011 9:49 pm

Re: Arduino Leonardo - Cannot upload code.

Postby abhimanyu » Tue Dec 18, 2012 8:10 am

Which version of Arduino IDE are you using? Get the latest version 1.5 here: Arduino IDE Download 1.0.3 or Beta version 1.5 for Due
You should compare the above mentioned VID and PID from the .inf file for Leonardo . They should match. If not, try changing these IDs and reinstalling the Drivers.

Return to “Arduino”

Who is online

Users browsing this forum: No registered users and 2 guests